blank PDF when using AddHTML with professional version


blank PDF when using AddHTML with professional version

Postby ifetayo on Thu Aug 20, 2009 3:15 pm

I developed a PDF solution for a client with the evaluation version of the software on my development machine. I suggested your product to them and they purchased it.

It functions perfectly in my environment however, blank PDFs are produced in the clients environment. I really need to get this resolved as soon as possible. Here is a sample of the code that I am using.

Code: Select all
Response.Expires = 0
Response.Buffer = TRUE
Response.Clear
Response.ContentType = "application/pdf"
Response.AddHeader "Content-Disposition", "attachment; filename=MJMTest.pdf"

dim PDF

set PDF = server.createobject("aspPDF.EasyPDF")

PDF.License("EasyPDF.lic")
PDF.DEBUG = True
strHTML = strHTML & "<img src=""ddslogo.gif"" width=""171"" height=""85"">"
strHTML = strHTML & "<table cellpadding=2 cellspacing=2 width=""980"" border=""1"" style=""font-size:8"">"
strHTML = strHTML & "<tr>"
strHTML = strHTML & "<td  align=center bgcolor=""#000066""><b><font size=3 color=""#FFFFFF"">"
strHTML = strHTML & "Driver Pay Report</font></b></td></tr>"
strHTML = strHTML & "<tr><td>Hello from MJM Innovations.</td></tr></table>"

'Page setup
PDF.SetMargins 20,20,30,30
PDF.SetEvenMargins 20,20,30,30, True
PDF.SetParameter "csHTML_TRFullPage", true 'do not separate table rows on pages.
PDF.AddHtml strHTML

strHTML = " <p align=""center""><b>Page <!-PDF.PAGENUMBER> of <!-PDF.PAGECOUNT></b></p> "
PDF.AddPattern 0, 1, 0, 10, strHTML

PDF.BinaryWrite
set PDF = nothing
ifetayo
 
Posts: 1
Joined: Fri Jun 26, 2009 8:27 pm

Return to PDF

Who is online

Users browsing this forum: No registered users and 1 guest

cron

Fatal error: Not able to open ./cache/data_global.php in D:\Hosting\6480136\html\ForosBB3\includes\acm\acm_file.php on line 106